aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2012-02-07 08:05:11 +0000
committerJörg Mayer <jmayer@loplof.de>2012-02-07 08:05:11 +0000
commitdc1a9e539b5aeb398b9965a58ccb9a221b2c71d7 (patch)
tree6ea24f8fac23e06d593da61a2a475554241c40ed /CMakeLists.txt
parentb84f2921ac9bf4cef209fab65b68686f4ad0f9e2 (diff)
Make sure that we only have to set (or pick up) the docdir environment
variable on the initial cmake run and not on later re-runs (like when some cmakelists.txt file changed and we call make). Of course this value should really be passed as an option instead of an environment variable but I want to document how to get the current approach working properly before switching to the proper approach. svn path=/trunk/; revision=40913
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b78529b1a..305cd262d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -449,7 +449,7 @@ endif()
# Basedir where to install guides
-set(DOC_DIR "$ENV{docdir}")
+set(DOC_DIR "$ENV{docdir}" CACHE FILEPATH "Installation directory for ug and dg pdfs.")
message(STATUS "docdir: ${DOC_DIR}")
if(ENABLE_GUIDES)