aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-07-14 03:10:25 +0100
committerJoão Valverde <j@v6e.pt>2021-09-20 13:27:11 +0100
commitc513188f52bc2f66e7700bab2e870f17ac973646 (patch)
treee5fc82e2bb459b67e52077c3aaf7b2b1266337b5 /CMakeLists.txt
parent977c73d5b419c4a53fb6ad032c0dc4ac2216ee93 (diff)
CMake: wsetargv.obj is specific to Visual Studio
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ada00a48d4..7b9acd8340 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -258,11 +258,11 @@ endif()
# build directory location). (Requires CMake 3.14)
set(CMAKE_BUILD_RPATH_USE_ORIGIN ON)
-if(WIN32)
+if(MSVC)
# Linking with wsetargv.obj enables "wildcard expansion" of
# command-line arguments.
set(WILDCARD_OBJ wsetargv.obj)
-endif(WIN32)
+endif()
include(CheckSymbolExists)