aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2012-06-20 20:59:43 +0000
committerJörg Mayer <jmayer@loplof.de>2012-06-20 20:59:43 +0000
commitc0da019caa57f8c90c71260436694f54e38198be (patch)
treef20e57e6191713d7f4ffe4219ca351f10c1e26e4 /CMakeLists.txt
parent49849233c382116d77f3a6d15a38135d5dbe3ee2 (diff)
Complete cmake support for netlink detection
svn path=/trunk/; revision=43421
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e074abbb40..eae1a8d5c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -312,6 +312,10 @@ if(ENABLE_GEOIP)
set(PACKAGELIST ${PACKAGELIST} GEOIP)
endif()
+if(ENABLE_NETLINK)
+ set(PACKAGELIST ${PACKAGELIST} NL)
+endif()
+
# Capabilities
if(ENABLE_CAP)
set(PACKAGELIST ${PACKAGELIST} CAP)
@@ -380,6 +384,9 @@ endif()
if(ENABLE_AIRPCAP)
set(HAVE_AIRPCAP 1)
endif()
+if(HAVE_LIBNL AND ENABLE_AIRPCAP)
+ message(ERROR "Airpcap and Libnl support are mutually exclusive")
+endif()
# No matter which version of GTK is present
if(GTK2_FOUND OR GTK3_FOUND)
set(GTK_FOUND ON)
@@ -904,6 +911,7 @@ if(BUILD_dumpcap AND PCAP_FOUND)
${GTHREAD2_LIBRARIES}
${ZLIB_LIBRARIES}
${APPLE_COCOA_LIBRARY}
+ ${LIBNL_LIBRARIES}
)
set(dumpcap_FILES
svnversion.h