aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <gharris@sonic.net>2021-02-14 12:54:42 -0800
committerGuy Harris <gharris@sonic.net>2021-02-14 14:43:42 -0800
commitc0711693ab166b22664a68f01224c4ba682e1207 (patch)
tree136ac536c7ec89f94b337ef9c3ef3f13469e6f03 /CMakeLists.txt
parent3387eef8367ca7b16b5515635f79d971bde97c5e (diff)
Enable -Wredundant-decls.
Add it to the default list of checks, and fix some errors it causes. (Sadly, it doesn't work in CLang.)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6e807af9e..26ff0aa36d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -582,6 +582,7 @@ else() # ! MSVC
-Wheader-guard
-Wcomma
-Wshorten-64-to-32
+ -Wredundant-decls
)
#
@@ -675,12 +676,6 @@ else() # ! MSVC
#
-Wcast-qual
#
- # Some generated ASN.1 dissectors block this one;
- # multiple function declarations for the same
- # function are being generated.
- #
- -Wredundant-decls
- #
# All the registration functions block these for now.
#
-Wmissing-prototypes