aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2018-11-29 14:46:21 +0100
committerAnders Broman <a.broman58@gmail.com>2018-11-29 22:11:27 +0000
commitbcd32b07e7d5fcc14e1683535a53fccdd6be70f3 (patch)
tree80d04cc05ab4fd255cc826466c8001bda11fca7a /CMakeLists.txt
parent7cc07bf7489fc5eef349c6aa862d6b109fe0d483 (diff)
Drop support for GnuTLS 2.12.x, require GnuTLS 3.2 or newer
Upcoming changes need GnuTLS >= 3.0.2. Require GnuTLS 3.2 (or newer) for licensing reasons. The Debian control file still mentions 3.2.14 because older packages linked with a GMP library that was not GPLv2+ compatible. RHEL6 only has 2.12.23, but is already unsupported anyway. Change-Id: I024b2a734ebb16b73a624bb2435c254e963d8b7d Reviewed-on: https://code.wireshark.org/review/30832 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 97fc411965..92e152e4cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -979,7 +979,9 @@ endif()
if(ENABLE_GNUTLS)
set(PACKAGELIST ${PACKAGELIST} GNUTLS)
# Minimum version needed.
- set(GNUTLS_OPTIONS "2.12.0")
+ # 3.0.2 due to GNUTLS_PRIVKEY_IMPORT_COPY
+ # 3.2.0 to remain GPLv2-compatible.
+ set(GNUTLS_OPTIONS "3.2.0")
endif()
# Kerberos