aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-01-22 09:29:57 -0800
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-01-22 18:57:23 +0000
commitbb48a9da99131deafef33e62ea8fb3e8bef87524 (patch)
tree11122019fdfb084f1b448f064d3114f29d3c9c31 /CMakeLists.txt
parentc1527c5d22a61cb54cbc6c7ecf006d16f780f95f (diff)
CMake: Fixup rpmbuild verbosity.
546dc0270c made things too quiet. Pass '-v' to rpmbuild if CMAKE_VERBOSE_MAKEFILE is set. Don't pass '--quiet'.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 298ca65773..f6e807af9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3040,8 +3040,8 @@ if(RPMBUILD_EXECUTABLE)
endforeach()
set(_rpmbuild_with_args)
- if(NOT CMAKE_VERBOSE_MAKEFILE)
- list(APPEND _rpmbuild_with_args --quiet)
+ if(CMAKE_VERBOSE_MAKEFILE)
+ list(APPEND _rpmbuild_with_args -v)
endif()
if(CMAKE_GENERATOR STREQUAL "Ninja")
list(APPEND _rpmbuild_with_args --with ninja)
@@ -3104,7 +3104,6 @@ if(RPMBUILD_EXECUTABLE)
--define "_topdir ${CMAKE_BINARY_DIR}/packaging/rpm"
--define "_prefix ${CMAKE_INSTALL_PREFIX}"
${_rpmbuild_with_args}
- -v
-ba SPECS/wireshark.spec
DEPENDS copy-dist
WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/packaging/rpm"