aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-04-08 10:02:52 -0700
committerAnders Broman <a.broman58@gmail.com>2019-04-09 04:28:36 +0000
commitba40851b277a04b126767583df5122eb51e38e0a (patch)
tree99bb83ed833f0be9a1255bca90fbcb2a99d6b94a /CMakeLists.txt
parentf3ef8575d4620a62f1c4609bf14961c3e78993f3 (diff)
Windows: Use an lz4 DLL built with vcpkg.
Update the Windows build environment to use lz4 packages built from a VS 2017 command prompt with set LZ4_VERSION=1.8.3 vcpkg remove lz4:x86-windows lz4:x64-windows vcpkg install lz4:x86-windows lz4:x64-windows vcpkg export lz4:x86-windows --output=lz4-%LZ4_VERSION%-win32ws --zip vcpkg export lz4:x64-windows --output=lz4-%LZ4_VERSION%-win64ws --zip The packages also include a PDB, so copy it to the build directory and add it to the PDB .zip. Change-Id: Icea512405d2085e5b271fa4a3ba8c0fe318b8cb5 Reviewed-on: https://code.wireshark.org/review/32785 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d782cf5372..95822cd0a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1732,6 +1732,7 @@ if(WIN32)
endif(LUA_FOUND)
if (LZ4_FOUND)
list (APPEND OPTIONAL_DLLS "${LZ4_DLL_DIR}/${LZ4_DLL}")
+ list (APPEND OPTIONAL_PDBS "${LZ4_DLL_DIR}/${LZ4_PDB}")
endif(LZ4_FOUND)
if (NGHTTP2_FOUND)
list (APPEND OPTIONAL_DLLS "${NGHTTP2_DLL_DIR}/${NGHTTP2_DLL}")