aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2019-02-12 19:02:07 -0800
committerGuy Harris <guy@alum.mit.edu>2019-02-13 03:05:11 +0000
commitaa1f314464d7c490fc0f07d5bfc831af98be4315 (patch)
treeefb06f8a4f74bb5684799e1e87a015bffa96aea9 /CMakeLists.txt
parent80e33fffce0d97f6c9d22f6ff46d1b3048210d47 (diff)
Fix directory containing compiled plugins in macOS.
They weren't getting put in the version-number subdirectory, so the plugin loader wasn't finding them. If that causes problems with codesign, then we need to either 1) figure out how to make it work with codesign or 2) for macOS, not put plugins in a version-number subdirectory ***AND*** change the plugin loading process not to look for compiled in a version-number subdirectory. Change-Id: I58d344b728d05369d35edef4e4e530f10034e930 Reviewed-on: https://code.wireshark.org/review/32000 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d937d724d9..c8ea2ea39b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1409,14 +1409,19 @@ else()
endif()
if(ENABLE_APPLICATION_BUNDLE)
- # codesign barfs if we put our plugins in a dotted version subdirectory,
- # e.g. PlugIns/Wireshark/3.1/epan so leave the version component out
- # for now.
+ #
+ # XXX - codesign barfs if we put our plugins in a dotted version
+ # subdirectory, e.g. PlugIns/Wireshark/3.1/epan, so we either
+ # need to figure out how to make it work, or need to leave the
+ # version component out *AND*, on macOS, look for compiled
+ # plugins in the plugins directory rather than in the dotted
+ # version subdirectory.
+ #
if(CMAKE_CFG_INTDIR STREQUAL ".")
- set(_plugin_dir "${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark")
+ set(_plugin_dir "${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark/${PROJECT_RELEASE_VERSION}")
else()
- # Xcode
- set(_plugin_dir "${CMAKE_BINARY_DIR}/run/$<CONFIG>/Wireshark.app/Contents/PlugIns/wireshark")
+ # Xcode
+ set(_plugin_dir "${CMAKE_BINARY_DIR}/run/$<CONFIG>/Wireshark.app/Contents/PlugIns/wireshark/${PROJECT_RELEASE_VERSION}")
endif()
elseif(WIN32 AND NOT CMAKE_CFG_INTDIR STREQUAL ".")
set(_plugin_dir "${CMAKE_BINARY_DIR}/run/$<CONFIG>/${PLUGIN_VERSION_DIR}")