aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-22 05:49:00 +0000
committerJoão Valverde <j@v6e.pt>2016-03-25 00:16:19 +0000
commita1ed7314137dfa5a96e7600ea1d3c6d127697d59 (patch)
tree59cda41b7e61c97a28eb8b130e49291c930a429b /CMakeLists.txt
parentb0db6a01a8de15a1eabb4a69135066034761dc2a (diff)
Add ax_lib_socket_nsl.m4 macro
Add SOCKET_LIBS and NSL_LIBS to global LIBS variables on platforms where it is required. Make configure checks for getaddrinfo/gethostname unconditional, that is handled with #ifdefs if necessary. Change-Id: Ia874038454fb9cf3bdbf8e6fd829f319e331837e Reviewed-on: https://code.wireshark.org/review/14560 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ad19e13d7..c33f58592a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1350,8 +1350,6 @@ else()
endif()
set(LIBEPAN_LIBS
-# @NSL_LIBS@ # -lnsl
-# @SOCKET_LIBS@ # -lsocket
# @SSL_LIBS@ # -lcrypto
epan
# $(plugin_ldadd) # in case of static
@@ -2129,8 +2127,6 @@ if(BUILD_randpkt)
wsutil
${M_LIBRARIES}
${PCAP_LIBRARIES}
-# @SOCKET_LIBS@
-# @NSL_LIBS@
${CARES_LIBRARIES}
${ZLIB_LIBRARIES}
)
@@ -2256,8 +2252,6 @@ if(BUILD_dumpcap AND PCAP_FOUND)
caputils
${PCAP_LIBRARIES}
${CAP_LIBRARIES}
-# @SOCKET_LIBS@
-# @NSL_LIBS@
${GLIB2_LIBRARIES}
${GTHREAD2_LIBRARIES}
${ZLIB_LIBRARIES}