aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-02-27 03:38:15 +0000
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-05-24 01:13:19 +0000
commit9ba97d12d6b1b2e6e06311375c07ce975fc08205 (patch)
tree33343e07bc84b8d930546c4e91a987712edb021b /CMakeLists.txt
parentde00cdd5129c30fdd138fe49da2003a5d3f74d8f (diff)
Add ws_debug() and use it
Replace most instances of ws_debug_printf() except in epan/dissectors and dissector plugins. Some replacements use printf(), some use ws_debug(), and some were removed because they were dead or judged to be temporary.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ed890da42..1277664389 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -823,6 +823,13 @@ else() # ! MSVC
elseif(DISABLE_ASSERT)
add_definitions(-DWS_DISABLE_ASSERT)
endif()
+ if(ENABLE_DEBUG)
+ add_definitions(-DWS_DEBUG)
+ elseif(CMAKE_VERSION VERSION_GREATER "3.11.99")
+ add_compile_definitions(
+ $<$<CONFIG:Debug>:WS_DEBUG>
+ )
+ endif()
set(WIRESHARK_LD_FLAGS
# See also CheckCLinkerFlag.cmake