aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2016-02-28 17:32:13 -0500
committerMichael Mann <mmann78@netscape.net>2016-03-03 18:28:32 +0000
commit8435145b1fe1bcdc93bc48e26346739e9962686f (patch)
tree7775e36d4d5654cb04b1427701ea2d6b48e62f66 /CMakeLists.txt
parentb70d1d7e14801754baee6af215b2162af38db211 (diff)
Create perl script to append existing AUTHORS file with information from git log.
new AUTHORS file can be created with "gen-authors" build parameter The "original" AUTHORS file has been fixed up to be kind to parsers (so no one gets excluded) and renamed to AUTHORS.src. This preserves the features authors worked on. For authors that didn't list features, they may be converted to just getting information from git. Change-Id: I9a4c4091e229f7f5e1c46d864527a98c1278e451 Reviewed-on: https://code.wireshark.org/review/14231 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b6c1783dd..0365ff5a15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2696,6 +2696,14 @@ add_custom_target(test-sh
-P ${CMAKE_SOURCE_DIR}/cmake/modules/GenerateTestSh.cmake
DEPENDS ${CMAKE_SOURCE_DIR}/cmake/modules/GenerateTestSh.cmake
)
+
+ADD_CUSTOM_TARGET(
+ gen-authors ALL
+ COMMAND git shortlog -sne | cut -c8- > ${CMAKE_SOURCE_DIR}/AUTHORS.git
+ COMMAND ${PERL_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/generate_authors.pl ${CMAKE_SOURCE_DIR}/AUTHORS.src ${CMAKE_SOURCE_DIR}/AUTHORS.git > ${CMAKE_SOURCE_DIR}/AUTHORS
+
+)
+
set_target_properties(test-sh PROPERTIES FOLDER "Tests")
add_custom_target(test-programs