aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-03-24 22:09:19 +0000
committerJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-03-29 06:08:02 +0100
commit7fee50274f36a5feba113aa9ad3e72ca37bf1466 (patch)
tree485b040aa4b6f00d9043c379db8fecdea4661f1b /CMakeLists.txt
parent2ba52cdc0e4216dafdfc32498fc0210c99449ec9 (diff)
Merge the caputils/ and capchild/ directories
The distinction between the different kinds of capture utility may not warrant a special subfolfer for each, and sometimes the distinction is not be clear or some functions could stradle multiple "categories" (like capture_ifinfo.[ch]). Simplify by having only a generic 'capture' subfolder. The separate CMake libraries are kept as a way to reuse object code efficiently.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc2d491783..ebc42d736b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1466,8 +1466,7 @@ endif()
set(PLUGIN_INSTALL_VERSION_LIBDIR "${PLUGIN_INSTALL_LIBDIR}/${PLUGIN_PATH_ID}")
set(PLUGIN_VERSION_DIR "plugins/${PLUGIN_PATH_ID}")
-add_subdirectory( capchild )
-add_subdirectory( caputils )
+add_subdirectory( capture )
add_subdirectory( doc )
add_subdirectory( docbook EXCLUDE_FROM_ALL )
add_subdirectory( epan )