aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-11-22 18:19:37 +0000
committerGuy Harris <guy@alum.mit.edu>2012-11-22 18:19:37 +0000
commit7cb9781379b900532ded16ed0b159b8c18c9392a (patch)
tree6970c72b291218ff1641184118356ef2228539f2 /CMakeLists.txt
parentbef6c70406227d3919ef20bbc756d7e11b080a48 (diff)
We don't need Cocoa or Core Services for anything.
What we *do* need is: the Application Services framework, for GUI applications; System Configuration, for anything that would try to get interface friendly names; Core Foundation for everything that uses either of those and/or everything that displays system version information. We're currently assuming that the only Apple platform on which we build is OS X, in which case we have the OS X frameworks; update a comment. cfutils.c is part of WIRESHARK_COMMON_SRC, which is included in tshark_FILES; it doesn't need to be included in tshark_FILES. svn path=/trunk/; revision=46147
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index acaadff4cf..db75c4efe3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -518,12 +518,14 @@ if(UNIX)
endif()
if(APPLE)
-#TODO verify that APPLE implies HAVE_OS_X_FRAMEWORKS
+ #
+ # We assume that APPLE means OS X so that we have the OS X
+ # frameworks.
+ #
set(HAVE_OS_X_FRAMEWORKS 1)
- FIND_LIBRARY (APPLE_CORE_SERVICES_LIBRARY CoreServices)
+ FIND_LIBRARY (APPLE_APPLICATION_SERVICES_LIBRARY ApplicationServices)
FIND_LIBRARY (APPLE_CORE_FOUNDATION_LIBRARY CoreFoundation)
FIND_LIBRARY (APPLE_SYSTEM_CONFIGURATION_LIBRARY SystemConfiguration)
- FIND_LIBRARY (APPLE_COCOA_LIBRARY Cocoa)
endif()
if(WIN32)
@@ -761,9 +763,9 @@ if(BUILD_wireshark AND GTK_FOUND)
codecs
${PORTAUDIO_LIBRARIES}
${LIBEPAN_LIBS}
+ ${APPLE_APPLICATION_SERVICES_LIBRARY}
${APPLE_CORE_SERVICES_LIBRARY}
${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
- ${APPLE_COCOA_LIBRARY}
${NL_LIBRARIES}
)
# qtshark and wireshark share wireshark_FILES
@@ -784,9 +786,9 @@ if(BUILD_qtshark AND QT_FOUND)
codecs
${PORTAUDIO_LIBRARIES}
${LIBEPAN_LIBS}
+ ${APPLE_APPLICATION_SERVICES_LIBRARY}
${APPLE_CORE_FOUNDATION_LIBRARY}
${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
- ${APPLE_COCOA_LIBRARY}
${NL_LIBRARIES}
)
# qtshark and wireshark share wireshark_FILES
@@ -811,7 +813,6 @@ if(BUILD_tshark)
set(tshark_FILES
capture_opts.c
capture_sync.c
- cfutils.c
tempfile.c
tshark-tap-register.c
tshark.c
@@ -942,7 +943,6 @@ if(BUILD_capinfos)
wsutil
${ZLIB_LIBRARIES}
${GCRYPT_LIBRARIES}
- ${APPLE_COCOA_LIBRARY}
)
set(capinfos_FILES
capinfos.c