aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-02-12 13:02:51 -0800
committerGerald Combs <gerald@wireshark.org>2019-02-12 21:04:19 +0000
commit6fef7cdc84db56164c898be3c041da5325d386ec (patch)
treed42b74b5823a735ee2f1cb22f32ca47676a6115d /CMakeLists.txt
parent4237718ecb313e6ed6bf05347a010c3103b1c864 (diff)
MacOS: Bundle and packaging updates
Update the code signing portions of the packaging scripts to match newer versions of macOS. Change-Id: I5e03611d8db61416955e797edcadfcff1404cc38 Reviewed-on: https://code.wireshark.org/review/31996 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0173a72e07..d937d724d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1409,11 +1409,14 @@ else()
endif()
if(ENABLE_APPLICATION_BUNDLE)
+ # codesign barfs if we put our plugins in a dotted version subdirectory,
+ # e.g. PlugIns/Wireshark/3.1/epan so leave the version component out
+ # for now.
if(CMAKE_CFG_INTDIR STREQUAL ".")
- set(_plugin_dir "${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark/${PROJECT_RELEASE_VERSION}")
+ set(_plugin_dir "${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark")
else()
# Xcode
- set(_plugin_dir "${CMAKE_BINARY_DIR}/run/$<CONFIG>/Wireshark.app/Contents/PlugIns/wireshark/${PROJECT_RELEASE_VERSION}")
+ set(_plugin_dir "${CMAKE_BINARY_DIR}/run/$<CONFIG>/Wireshark.app/Contents/PlugIns/wireshark")
endif()
elseif(WIN32 AND NOT CMAKE_CFG_INTDIR STREQUAL ".")
set(_plugin_dir "${CMAKE_BINARY_DIR}/run/$<CONFIG>/${PLUGIN_VERSION_DIR}")