aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Thacker <johnthacker@gmail.com>2020-12-21 11:37:14 -0500
committerAndersBroman <a.broman58@gmail.com>2021-01-01 12:24:42 +0000
commit5c936174c6980e93673eae4330792576776959c4 (patch)
tree51f4d76e1b5bd155ba93951affee0291f3942c51 /CMakeLists.txt
parent85bf15fd7614cf3291b0c9d0cb682bdba5ad920b (diff)
libgcrypt: Bump version number to 1.5.0
With RHEL/CentOS 6 EOL and already unsupported by Wireshark, there's no reason to keep the minimum version of libgcrypt below 1.5.0 (which was released 9.5 years ago). Version 1.6.0 is a big improvement in functionality, but RHEL/CentOS 7 is stuck on 1.5.3 (As an aside, GCRYPT_VERSION_NUMBER wasn't defined until 1.5.1, so this change will make us actually use the libgcrypt AES-WRAP handling on 1.5.0)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8eeba499f2..096d8836f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1044,7 +1044,7 @@ find_package(GMODULE2)
reset_find_package(GTHREAD2)
find_package(GTHREAD2 REQUIRED)
reset_find_package(GCRYPT GCRYPT_ERROR_LIBRARY)
-find_package(GCRYPT "1.4.2" REQUIRED)
+find_package(GCRYPT "1.5.0" REQUIRED)
# C Asynchronous resolver
reset_find_package(CARES)
find_package(CARES "1.5.0" REQUIRED)