aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-01-09 10:49:24 -0800
committerAndersBroman <a.broman58@gmail.com>2021-01-10 15:10:10 +0000
commit546dc0270c10e0c58acb43ea1c33a03c2aa38c40 (patch)
treefa22a9211d5643015c40c1d06f8e886c41ea02f6 /CMakeLists.txt
parent0d820ddc8d2dde1070c312093699cc34623c36c5 (diff)
CMake: Make the rpmbuild output quiet by default.
If CMAKE_VERBOSE_MAKEFILE is false (the default), pass `--quiet` to rpmbuild.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6361bed624..298ca65773 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1227,8 +1227,7 @@ if(BUILD_wireshark OR BUILD_sharkd)
endif()
endif()
-# dist target that prepares source dir
-# XXX Duplicated in the RPM section below.
+# Generate the distribution tarball.
add_custom_target(dist
COMMAND ${CMAKE_BINARY_DIR}/packaging/source/git-export-release.sh -d "${CMAKE_BINARY_DIR}"
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
@@ -3041,6 +3040,9 @@ if(RPMBUILD_EXECUTABLE)
endforeach()
set(_rpmbuild_with_args)
+ if(NOT CMAKE_VERBOSE_MAKEFILE)
+ list(APPEND _rpmbuild_with_args --quiet)
+ endif()
if(CMAKE_GENERATOR STREQUAL "Ninja")
list(APPEND _rpmbuild_with_args --with ninja)
endif()