aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <gharris@sonic.net>2021-04-02 16:30:26 -0700
committerGuy Harris <gharris@sonic.net>2021-04-02 16:30:26 -0700
commit52030fdca764a317b53996fcdbdace7c9c78221d (patch)
tree4081e7d0e4ac46d7b66873964a6cb1468c5dc273 /CMakeLists.txt
parent074b33e465aaa2e04d1e1ace126d4528271191fe (diff)
Try not disabling designated initializer overides.
Sometimes initializing the same field twice indicates a bug, so see whether we can leave it enabled and suppress the warning in cases where it's probably not a bug (too bad GCC didn't let you specify a default initializer with, for example: int foo[16] = { [] = 17, [12] = 34 }; which would mean we wouldn't have to suppress that warning in ui/text_import.c). Note also that not all compilers that can produce this warning call the option "-Woverride-init".
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8cde89f5be..52d6d64f5c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -677,15 +677,6 @@ else() # ! MSVC
# -Wimplicit-function-declaration into an error by default.
#
-Werror=implicit
- #
- # the value used for uninitialized fields is 0 and cannot be changed
- # the workaround is to initialize everything to the wanted default
- # any subsequent initializers then cause this warning
- #
- # XXX: in theory c++20+ could have this issue aswell, but we don't
- # use designated initializers in c++ code anyway.
- #
- -Wno-override-init
)
#