aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2018-09-24 11:42:48 -0400
committerJeff Morriss <jeff.morriss.ws@gmail.com>2018-09-24 15:57:17 +0000
commit4b4c11944c72952bf39d6fe41a7fe587cc3ccef0 (patch)
treebc0856b67b3e222b17bbfe85cb4b38352c893b17 /CMakeLists.txt
parent3b34b286ab14f5458397ccbb1174939fa2c548e6 (diff)
RPM packaging: maxminddb is optional.
Don't require the RPM to include maxminddb if we couldn't find it. Treat it like the other optional packages: enable it in the RPM iff we found it. IOW if cmake ran and will build Wireshark [without maxminddb] you'll also be able to build an RPM [without maxminddb]. Change-Id: I012b75ae44e9289275b68db2eb804fc45bb0d330 Reviewed-on: https://code.wireshark.org/review/29807 Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f58a1dbc9e..f20ced11a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2663,7 +2663,7 @@ if(RPMBUILD_EXECUTABLE)
if (BUILD_wireshark)
list(APPEND _rpmbuild_with_args --with qt5)
endif()
- if (BUILD_mmdbresolve)
+ if (MAXMINDDB_FOUND)
list(APPEND _rpmbuild_with_args --with mmdbresolve)
endif()
if (LUA_FOUND)