aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2014-08-20 13:31:19 +0100
committerEvan Huus <eapache@gmail.com>2014-08-20 19:25:28 +0000
commit4ac0438e46f80fb70f4be05e0a45dd08fe74fe8d (patch)
tree4e05d5d6accb8d0173c6bc3de19128e21537a710 /CMakeLists.txt
parent8fc0ee4c899e5eee8d84cafdd31c58c94eec6a8f (diff)
In Visual Studio builds, enable the L4 warning
4189: Local variable is initialized but not referenced Fix some variables found by this Change-Id: Icc13def5413f1fe885ec25e659462c8906a6cfa0 Reviewed-on: https://code.wireshark.org/review/3748 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fa57e095c..a928f69f91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -181,7 +181,8 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
# Additional compiler warnings to be treated as "Level 3"
# when compiling Wireshark sources. (Selected from "level 4" warnings).
## 4295: array is too small to include a terminating null character
- set(WARNINGS_CFLAGS "/w34295")
+ ## 4189: local variable is initialized but not referenced
+ set(WARNINGS_CFLAGS "/w34295 /w34189")
# FIXME: WINPCAP_VERSION cannot be determined from source or executable.
set(WINPCAP_VERSION "unknown")