aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Eszlari <peter.eszlari@gmail.com>2020-12-06 15:38:41 +0100
committerJörg Mayer <jmghc@loplof.de>2020-12-10 18:11:12 +0000
commit42a09ad02e7f51707927230ecd124938462d18c0 (patch)
tree8d55c0ac2cbd0d231d30082dac60e07075e0b024 /CMakeLists.txt
parent9a46fabf5299fb0b634dfc0f6368d8201e847d73 (diff)
Linux: rename metadata according to spec
https://www.freedesktop.org/software/appstream/docs/sect-Metadata-Application.html https://specifications.freedesktop.org/desktop-entry-spec/latest/ar01s02.html#desktop-file-id
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c1ab0a9a8..20be41a92c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3150,7 +3150,7 @@ if(LINUXDEPLOYQT_EXECUTABLE AND APPIMAGETOOL_EXECUTABLE)
# https://github.com/probonopd/linuxdeployqt/wiki/Custom-wrapper-script-instead-of-AppRun
add_custom_target(appimage-prep
COMMAND ${LINUXDEPLOYQT_EXECUTABLE}
- "${_ai_appdir}/usr/share/applications/wireshark.desktop"
+ "${_ai_appdir}/usr/share/applications/org.wireshark.Wireshark.desktop"
${_exe_args}
COMMAND rm -f "${_ai_appdir}/AppRun"
COMMAND install
@@ -3233,28 +3233,28 @@ install(FILES ${SHARK_PUBLIC_HEADERS}
# Install icons and other desktop files for Freedesktop.org-compliant desktops.
if((BUILD_wireshark AND QT_FOUND) AND NOT (WIN32 OR APPLE))
- install(FILES wireshark-mime-package.xml
+ install(FILES org.wireshark.Wireshark-mime.xml
DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/mime/packages"
- RENAME wireshark.xml
+ RENAME org.wireshark.Wireshark.xml
)
- install(FILES wireshark.appdata.xml
- DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/appdata"
+ install(FILES org.wireshark.Wireshark.metainfo.xml
+ DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/metainfo"
)
if(BUILD_wireshark AND QT_FOUND)
- install(FILES wireshark.desktop
+ install(FILES org.wireshark.Wireshark.desktop
DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
endif()
foreach(size 16 24 32 48 64 128 256)
install(FILES image/wsicon${size}.png
DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${size}x${size}/apps"
- RENAME wireshark.png)
+ RENAME org.wireshark.Wireshark.png)
install(FILES image/WiresharkDoc-${size}.png
DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${size}x${size}/mimetypes"
- RENAME application-wireshark-doc.png)
+ RENAME org.wireshark.Wireshark-mimetype.png)
endforeach()
install(FILES image/wsicon.svg
DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/scalable/apps"
- RENAME wireshark.svg)
+ RENAME org.wireshark.Wireshark.svg)
endif()
install(