aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2011-08-30 11:44:21 +0000
committerJörg Mayer <jmayer@loplof.de>2011-08-30 11:44:21 +0000
commit3a48ef3e02debb403127802e6f0b70918907e5e5 (patch)
tree212365480175d65593cd8acaa94e8990aa972e31 /CMakeLists.txt
parentad0533504336156dae75a46e5ed66b9779058050 (diff)
Make it possible to disable building with libpcap.
svn path=/trunk/; revision=38795
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09100d7fd1..771add6ac7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -227,7 +227,7 @@ endif()
# - set HAVE_XXX
#The minimum package list
-set(PACKAGELIST GLIB2 GMODULE2 PCAP M LEX YACC Perl SH PythonInterp)
+set(PACKAGELIST GLIB2 GMODULE2 M LEX YACC Perl SH PythonInterp)
set(GLIB2_FIND_REQUIRED)
set(GLIB2_MIN_VERSION 2.14.0)
set(PCAP_REQUIRED)
@@ -235,6 +235,10 @@ set(M_REQUIRED)
set(PACKAGELIST ${PACKAGELIST} HtmlViewer)
+if(ENABLE_PCAP)
+ set(PACKAGELIST ${PACKAGELIST} PCAP)
+endif()
+
#Build the gui ?
if(BUILD_wireshark)
if(ENABLE_GTK3)