aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2020-11-30 14:57:01 -0800
committerAndersBroman <a.broman58@gmail.com>2020-12-01 08:32:44 +0000
commit3a42bf0de2b9e35efcc3cea38153ab95cb71b352 (patch)
tree0a87993bbfc6d22591416e314972e324c1f45358 /CMakeLists.txt
parent6ba539fe05b8ab1703e814763d1298d857bf875d (diff)
Windows: Upgrade brotli, libmaxminddb, lz4, and snappy.
Upgrade brotli to 1.0.9, libmaxminddb to 1.4.3, lz4 to 1.9.2, and snappy to 1.1.8.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4ed6c6db6..5893baa28b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1882,9 +1882,12 @@ if(WIN32)
list (APPEND OPTIONAL_DLLS "${CARES_DLL_DIR}/${CARES_DLL}")
list (APPEND OPTIONAL_PDBS "${CARES_DLL_DIR}/${CARES_PDB}")
endif(CARES_FOUND)
- if (MAXMINDDB_FOUND)
- list (APPEND OPTIONAL_DLLS "${MAXMINDDB_DLL_DIR}/${MAXMINDDB_DLL}")
- endif(MAXMINDDB_FOUND)
+ # vcpkg's libmaxminddb is static-only for now. This can be uncommented when
+ # https://github.com/maxmind/libmaxminddb/commit/3998f42bdb6678cbaa1a543057e5c81ba1668ac2
+ # percolates up to vcpkg.
+ # if (MAXMINDDB_FOUND)
+ # list (APPEND OPTIONAL_DLLS "${MAXMINDDB_DLL_DIR}/${MAXMINDDB_DLL}")
+ # endif(MAXMINDDB_FOUND)
if (LIBSSH_FOUND)
list (APPEND OPTIONAL_DLLS "${LIBSSH_DLL_DIR}/${LIBSSH_DLL}")
endif(LIBSSH_FOUND)
@@ -2832,6 +2835,8 @@ if (MAXMINDDB_FOUND)
set(mmdbresolve_LIBS
# Note: libmaxminddb is not GPL-2 compatible.
${MAXMINDDB_LIBRARY}
+ # Needed for CMake-built libmaxminddb.lib <= 1.43.
+ ${WIN_WS2_32_LIBRARY}
)
set(mmdbresolve_FILES
mmdbresolve.c