aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-04-26 11:31:25 -0700
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-04-27 05:36:49 +0000
commit2549e51ee4720262c66b97ffd9e0a329eb340eea (patch)
tree46418c1aaf38cae26a5680466ca427b7df11640f /CMakeLists.txt
parentff9a89c8a2bb0fbe34fea10324a213b84b3232e7 (diff)
Remove unneeded c-ares checks.
C-ares has been mandatory since 451a241e50. Remove some checks that are no longer needed. Rename OPTIONAL_DLLS to THIRD_PARTY_DLLS and OPTIONAL_PDBS to THIRD_PARTY_PDBS in CMakeLists.txt, which is more accurate.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt79
1 files changed, 37 insertions, 42 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 119710cf34..4b0c604543 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1956,75 +1956,73 @@ if(WIN32)
)
endif()
- # Optional DLLs and PDBs.
- set (OPTIONAL_DLLS)
- set (OPTIONAL_PDBS)
+ # Third party DLLs and PDBs.
+ set (THIRD_PARTY_DLLS)
+ set (THIRD_PARTY_PDBS)
if (AIRPCAP_FOUND)
- list (APPEND OPTIONAL_DLLS "${AIRPCAP_DLL_DIR}/${AIRPCAP_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${AIRPCAP_DLL_DIR}/${AIRPCAP_DLL}")
endif(AIRPCAP_FOUND)
- if (CARES_FOUND)
- list (APPEND OPTIONAL_DLLS "${CARES_DLL_DIR}/${CARES_DLL}")
- list (APPEND OPTIONAL_PDBS "${CARES_DLL_DIR}/${CARES_PDB}")
- endif(CARES_FOUND)
+ list (APPEND THIRD_PARTY_DLLS "${CARES_DLL_DIR}/${CARES_DLL}")
+ list (APPEND THIRD_PARTY_PDBS "${CARES_DLL_DIR}/${CARES_PDB}")
# vcpkg's libmaxminddb is static-only for now. This can be uncommented when
# https://github.com/maxmind/libmaxminddb/commit/3998f42bdb6678cbaa1a543057e5c81ba1668ac2
# percolates up to vcpkg.
# if (MAXMINDDB_FOUND)
- # list (APPEND OPTIONAL_DLLS "${MAXMINDDB_DLL_DIR}/${MAXMINDDB_DLL}")
+ # list (APPEND THIRD_PARTY_DLLS "${MAXMINDDB_DLL_DIR}/${MAXMINDDB_DLL}")
# endif(MAXMINDDB_FOUND)
if (LIBSSH_FOUND)
foreach( _dll ${LIBSSH_DLLS} )
- list (APPEND OPTIONAL_DLLS "${LIBSSH_DLL_DIR}/${_dll}")
+ list (APPEND THIRD_PARTY_DLLS "${LIBSSH_DLL_DIR}/${_dll}")
endforeach(_dll)
endif(LIBSSH_FOUND)
foreach( _dll ${GCRYPT_DLLS} )
- list (APPEND OPTIONAL_DLLS "${GCRYPT_DLL_DIR}/${_dll}")
+ list (APPEND THIRD_PARTY_DLLS "${GCRYPT_DLL_DIR}/${_dll}")
endforeach(_dll)
foreach( _dll ${GNUTLS_DLLS} )
- list (APPEND OPTIONAL_DLLS "${GNUTLS_DLL_DIR}/${_dll}")
+ list (APPEND THIRD_PARTY_DLLS "${GNUTLS_DLL_DIR}/${_dll}")
endforeach(_dll)
foreach( _dll ${KERBEROS_DLLS} )
- list (APPEND OPTIONAL_DLLS "${KERBEROS_DLL_DIR}/${_dll}")
+ list (APPEND THIRD_PARTY_DLLS "${KERBEROS_DLL_DIR}/${_dll}")
endforeach(_dll)
if (LUA_FOUND)
- list (APPEND OPTIONAL_DLLS "${LUA_DLL_DIR}/${LUA_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${LUA_DLL_DIR}/${LUA_DLL}")
endif(LUA_FOUND)
if (LZ4_FOUND)
- list (APPEND OPTIONAL_DLLS "${LZ4_DLL_DIR}/${LZ4_DLL}")
- list (APPEND OPTIONAL_PDBS "${LZ4_DLL_DIR}/${LZ4_PDB}")
+ list (APPEND THIRD_PARTY_DLLS "${LZ4_DLL_DIR}/${LZ4_DLL}")
+ list (APPEND THIRD_PARTY_PDBS "${LZ4_DLL_DIR}/${LZ4_PDB}")
endif(LZ4_FOUND)
if (ZSTD_FOUND)
- list (APPEND OPTIONAL_DLLS "${ZSTD_DLL_DIR}/${ZSTD_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${ZSTD_DLL_DIR}/${ZSTD_DLL}")
endif(ZSTD_FOUND)
if (NGHTTP2_FOUND)
- list (APPEND OPTIONAL_DLLS "${NGHTTP2_DLL_DIR}/${NGHTTP2_DLL}")
- list (APPEND OPTIONAL_PDBS "${NGHTTP2_DLL_DIR}/${NGHTTP2_PDB}")
+ list (APPEND THIRD_PARTY_DLLS "${NGHTTP2_DLL_DIR}/${NGHTTP2_DLL}")
+ list (APPEND THIRD_PARTY_PDBS "${NGHTTP2_DLL_DIR}/${NGHTTP2_PDB}")
endif(NGHTTP2_FOUND)
if (SBC_FOUND)
- list (APPEND OPTIONAL_DLLS "${SBC_DLL_DIR}/${SBC_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${SBC_DLL_DIR}/${SBC_DLL}")
endif(SBC_FOUND)
if (SPANDSP_FOUND)
- list (APPEND OPTIONAL_DLLS "${SPANDSP_DLL_DIR}/${SPANDSP_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${SPANDSP_DLL_DIR}/${SPANDSP_DLL}")
endif(SPANDSP_FOUND)
if (BCG729_FOUND)
- list (APPEND OPTIONAL_DLLS "${BCG729_DLL_DIR}/${BCG729_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${BCG729_DLL_DIR}/${BCG729_DLL}")
endif(BCG729_FOUND)
if (ILBC_FOUND)
- list (APPEND OPTIONAL_DLLS "${ILBC_DLL_DIR}/${ILBC_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${ILBC_DLL_DIR}/${ILBC_DLL}")
endif(ILBC_FOUND)
if (OPUS_FOUND)
- list (APPEND OPTIONAL_DLLS "${OPUS_DLL_DIR}/${OPUS_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${OPUS_DLL_DIR}/${OPUS_DLL}")
endif(OPUS_FOUND)
if (LIBXML2_FOUND)
foreach( _dll ${LIBXML2_DLLS} )
- list (APPEND OPTIONAL_DLLS "${LIBXML2_DLL_DIR}/${_dll}")
+ list (APPEND THIRD_PARTY_DLLS "${LIBXML2_DLL_DIR}/${_dll}")
endforeach(_dll)
foreach( _pdb ${LIBXML2_PDBS} )
- list (APPEND OPTIONAL_PDBS "${LIBXML2_DLL_DIR}/${_pdb}")
+ list (APPEND THIRD_PARTY_PDBS "${LIBXML2_DLL_DIR}/${_pdb}")
endforeach(_pdb)
endif(LIBXML2_FOUND)
if (SMI_FOUND)
- list (APPEND OPTIONAL_DLLS "${SMI_DLL_DIR}/${SMI_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${SMI_DLL_DIR}/${SMI_DLL}")
# Wireshark.nsi wants SMI_DIR which is the base SMI directory
get_filename_component(SMI_DIR ${SMI_DLL_DIR} DIRECTORY)
add_custom_command(TARGET copy_cli_dlls PRE_BUILD
@@ -2065,41 +2063,41 @@ if(WIN32)
)
endif(SMI_FOUND)
if (SNAPPY_FOUND)
- list (APPEND OPTIONAL_DLLS "${SNAPPY_DLL_DIR}/${SNAPPY_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${SNAPPY_DLL_DIR}/${SNAPPY_DLL}")
endif(SNAPPY_FOUND)
if (WINSPARKLE_FOUND)
- list (APPEND OPTIONAL_DLLS "${WINSPARKLE_DLL_DIR}/${WINSPARKLE_DLL}")
+ list (APPEND THIRD_PARTY_DLLS "${WINSPARKLE_DLL_DIR}/${WINSPARKLE_DLL}")
endif(WINSPARKLE_FOUND)
if (ZLIB_FOUND)
- list (APPEND OPTIONAL_DLLS "${ZLIB_DLL_DIR}/${ZLIB_DLL}")
- list (APPEND OPTIONAL_PDBS "${ZLIB_DLL_DIR}/${ZLIB_PDB}")
+ list (APPEND THIRD_PARTY_DLLS "${ZLIB_DLL_DIR}/${ZLIB_DLL}")
+ list (APPEND THIRD_PARTY_PDBS "${ZLIB_DLL_DIR}/${ZLIB_PDB}")
endif(ZLIB_FOUND)
if (BROTLI_FOUND)
foreach( _dll ${BROTLI_DLLS} )
- list (APPEND OPTIONAL_DLLS "${BROTLI_DLL_DIR}/${_dll}")
+ list (APPEND THIRD_PARTY_DLLS "${BROTLI_DLL_DIR}/${_dll}")
endforeach(_dll)
endif(BROTLI_FOUND)
# With libs downloaded to c:/wireshark-win64-libs this currently
# (early 2018) expands to about 1900 characters.
- if (OPTIONAL_DLLS)
+ if (THIRD_PARTY_DLLS)
add_custom_command(TARGET copy_cli_dlls PRE_BUILD
COMMAND ${CMAKE_COMMAND} -E copy_if_different
- ${OPTIONAL_DLLS}
+ ${THIRD_PARTY_DLLS}
"${_dll_output_dir}"
VERBATIM
)
- install(FILES ${OPTIONAL_DLLS} DESTINATION "${CMAKE_INSTALL_BINDIR}")
- endif(OPTIONAL_DLLS)
+ install(FILES ${THIRD_PARTY_DLLS} DESTINATION "${CMAKE_INSTALL_BINDIR}")
+ endif(THIRD_PARTY_DLLS)
- if (OPTIONAL_PDBS)
+ if (THIRD_PARTY_PDBS)
add_custom_command(TARGET copy_cli_dlls PRE_BUILD
COMMAND ${CMAKE_COMMAND} -E copy_if_different
- ${OPTIONAL_PDBS}
+ ${THIRD_PARTY_PDBS}
"${_dll_output_dir}"
VERBATIM
)
- endif(OPTIONAL_PDBS)
+ endif(THIRD_PARTY_PDBS)
add_dependencies(epan copy_cli_dlls)
@@ -3198,9 +3196,6 @@ if(RPMBUILD_EXECUTABLE)
if (LZ4_FOUND AND SNAPPY_FOUND)
list(APPEND _rpmbuild_with_args --with lz4_and_snappy)
endif()
- if (CARES_FOUND)
- list(APPEND _rpmbuild_with_args --with c_ares)
- endif()
if (SPANDSP_FOUND)
list(APPEND _rpmbuild_with_args --with spandsp)
endif()