aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-03-29 01:32:20 +0100
committerJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-03-29 01:33:39 +0100
commit22cf2cb345b16f9783165e9cfc80ed9a97a11ca0 (patch)
tree2de1a8b5ea52613fe995ca88cba75431e2d9ec2e /CMakeLists.txt
parentd7401147b495fad705fca8c4523137b18de33183 (diff)
CMake: Set CMake Policy CMP0071 to NEW
This policy says: "Since version 3.10, CMake processes regular and GENERATED source files in AUTOMOC and AUTOUIC. In earlier CMake versions, only regular source files were processed. GENERATED source files were ignored silently." We are currently running AUTOMOC/RCC/UIC on too many files unnecessarily and that should be improved. CMake 3.20 introduced some changes related with this that broke the build (issue #17314) and need further investigation. Meanwhile setting this policy to NEW shouldn't break anything and silences some noisy CMake warnings.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99ce96ba3c..fc2d491783 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,9 @@ endif()
if(POLICY CMP0069)
cmake_policy(SET CMP0069 NEW)
endif()
+if(POLICY CMP0071)
+ cmake_policy(SET CMP0071 NEW)
+endif()
if(POLICY CMP0074)
cmake_policy(SET CMP0074 NEW)
endif()