aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRyan Doyle <ryan@doylenet.net>2015-10-29 20:01:49 +1100
committerGerald Combs <gerald@wireshark.org>2015-10-29 20:59:50 +0000
commit2014eb0ad3221acf319c95cd968cf11e44174137 (patch)
tree208933574d89e2b774c71c6713ed6494d0dcaeb1 /CMakeLists.txt
parent81bf8edc52f1c8df557bbf4102182bcae93e0a4d (diff)
CMake: Fix compatibility with CMake 3
The version of CMake I use (3.2.2) failed to parse the CMakeLists.txt Change-Id: I146c5a5ba8cd6fa6236b53039a31cc085bf5b460 Reviewed-on: https://code.wireshark.org/review/11392 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0d0cd2fd1..6d06c10c23 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2620,7 +2620,7 @@ else ()
if (NOT "${HARDENING_CHECK_EXECUTABLE}" STREQUAL "HARDENING_CHECK_EXECUTABLE-NOTFOUND")
foreach(_prog ${PROGLIST})
get_target_property(_prog_dir ${_prog} RUNTIME_OUTPUT_DIRECTORY)
- if (${_prog_dir} STREQUAL "_prog_dir-NOTFOUND")
+ if ("${_prog_dir}" STREQUAL "_prog_dir-NOTFOUND")
set(_prog_dir "${CMAKE_BINARY_DIR}/run")
endif()
set(_prog_paths ${_prog_paths} "${_prog_dir}/${_prog}")