aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-02-08 12:04:02 +0100
committerPeter Wu <peter@lekensteyn.nl>2019-02-10 14:50:49 +0000
commit07910e841e67ffbbcfb4ea8221244dab4ba13017 (patch)
tree830fce9c79fde6c60072ad0c4744ae3c08fceddb /CMakeLists.txt
parent55db3d523dbe0a005ac8066f1b6106c3115cec7f (diff)
RPM: respect options for disabling Qt, SpanDSP and BCG729
"%bcond_without" enables a feature by default. Be sure to explicitly disable features to match the requested configuration. Change-Id: I90687f35bcd953670e147be9e70af03aaeaef5dc Ping-Bug: 14606 Reviewed-on: https://code.wireshark.org/review/31933 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5f61f6a40..93df11ac78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2715,8 +2715,8 @@ if(RPMBUILD_EXECUTABLE)
if(CCACHE_EXECUTABLE)
list(APPEND _rpmbuild_with_args --with ccache)
endif()
- if (BUILD_wireshark)
- list(APPEND _rpmbuild_with_args --with qt5)
+ if(NOT BUILD_wireshark)
+ list(APPEND _rpmbuild_with_args --without qt5)
endif()
if (MAXMINDDB_FOUND)
list(APPEND _rpmbuild_with_args --with mmdbresolve)