aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2022-05-23 13:23:42 +0100
committerJoão Valverde <j@v6e.pt>2022-05-23 23:03:59 +0100
commitce52af1a3286bd1f8069fba7240f3e98b50ab7e0 (patch)
tree25fd897423b574645f5c970c4c1a8fb10b2cc466 /CMakeLists.txt
parentf6fdf53ecaf6ef072621bde52dbf9bf21a2bf204 (diff)
CMake: Disable errors with -Walloc-size-larger-than=
This seems to be buggy and have a complicated interaction with the GCC optimizer. Disable hard failures so we can focus on actual issues and deal with dormant false positives when it is convenient. Ping #18089
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99a7eecb2d..cdd830b6f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -656,6 +656,9 @@ else() # ! MSVC
# until these procedural issues can be fixed or at least mitigated.
#
-Wno-error=maybe-uninitialized
+ # Disable errors for another warning that is prone to guesswork
+ # and false positives.
+ -Wno-error=alloc-size-larger-than=
#
# Converting from g_printf() and g_snprintf() to stdio.h turns
# up many of these warnings. They will have to be handled later.