aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2023-01-18 00:46:21 +0000
committerJoão Valverde <j@v6e.pt>2023-01-18 03:35:13 +0000
commitfe7bfdf6caac9204ab5f34eeba7b0f4a0314d3cd (patch)
tree135f1addfb0bd60441095b6122fc40fce4909115 /CMakeLists.txt
parent728073ade057f5376f6b984115a962e8e812264b (diff)
CMake: Require explicit installation of development headers
Develpment headers are a sizeable part of the binary installation and most users won't ever require them. It's recommended to package them separately in a devel package or SDK. Create a CMake installation component for development headers and add the EXCLUDE_FROM_ALL property. Headers can be installed using the invocation: cmake --install <dir> --component Development
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02a2bcc0e6..bced6c0932 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3766,6 +3766,8 @@ set(SHARK_PUBLIC_HEADERS
install(FILES ${SHARK_PUBLIC_HEADERS}
DESTINATION ${PROJECT_INSTALL_INCLUDEDIR}
+ COMPONENT "Development"
+ EXCLUDE_FROM_ALL
)
# Install icons and other desktop files for Freedesktop.org-compliant desktops.
@@ -3824,6 +3826,9 @@ install(
"${CMAKE_BINARY_DIR}/wireshark.pc"
DESTINATION
${CMAKE_INSTALL_LIBDIR}/pkgconfig
+ COMPONENT
+ "Development"
+ EXCLUDE_FROM_ALL
)
install(
@@ -3875,10 +3880,15 @@ install(
${CMAKE_BINARY_DIR}/WiresharkConfigVersion.cmake
DESTINATION
${WIRESHARK_INSTALL_CMAKEDIR}
+ COMPONENT
+ "Development"
+ EXCLUDE_FROM_ALL
)
install(EXPORT WiresharkTargets
DESTINATION ${WIRESHARK_INSTALL_CMAKEDIR}
+ COMPONENT "Development"
+ EXCLUDE_FROM_ALL
)
if (DOXYGEN_EXECUTABLE)