aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2019-09-27 23:03:13 +0100
committerJoão Valverde <j@v6e.pt>2019-10-09 13:24:58 +0000
commitf1285fcf061669702ca1accd7b2c50ebc8198993 (patch)
treee4e0e83535f5de15388d4af4e80841b28ef99a89 /CMakeLists.txt
parent931a80492da92fe29fab6ac41eb219a6ca6b53d7 (diff)
CMake: Don't install HTML manuals twice
HTML docs are installed to both $docdir and $pkgdatadir. Fix that to install to $docdir only. Change-Id: I115158585b6df9170d9a01249adbc8548df91f14 Reviewed-on: https://code.wireshark.org/review/34640 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9ae5d57ca..f354b999f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1729,42 +1729,8 @@ set(INSTALL_FILES
smi_modules
wka
docbook/ws.css
- ${CMAKE_BINARY_DIR}/doc/AUTHORS-SHORT
- ${CMAKE_BINARY_DIR}/doc/androiddump.html
- ${CMAKE_BINARY_DIR}/doc/udpdump.html
- ${CMAKE_BINARY_DIR}/doc/capinfos.html
- ${CMAKE_BINARY_DIR}/doc/captype.html
- ${CMAKE_BINARY_DIR}/doc/ciscodump.html
- ${CMAKE_BINARY_DIR}/doc/dftest.html
- ${CMAKE_BINARY_DIR}/doc/dumpcap.html
- ${CMAKE_BINARY_DIR}/doc/editcap.html
- ${CMAKE_BINARY_DIR}/doc/extcap.html
- ${CMAKE_BINARY_DIR}/doc/mergecap.html
- ${CMAKE_BINARY_DIR}/doc/randpkt.html
- ${CMAKE_BINARY_DIR}/doc/randpktdump.html
- ${CMAKE_BINARY_DIR}/doc/rawshark.html
- ${CMAKE_BINARY_DIR}/doc/reordercap.html
- ${CMAKE_BINARY_DIR}/doc/sshdump.html
- ${CMAKE_BINARY_DIR}/doc/text2pcap.html
- ${CMAKE_BINARY_DIR}/doc/tshark.html
- ${CMAKE_BINARY_DIR}/doc/wireshark.html
- ${CMAKE_BINARY_DIR}/doc/wireshark-filter.html
)
-if(MAXMINDDB_FOUND)
- list(APPEND INSTALL_FILES ${CMAKE_BINARY_DIR}/doc/mmdbresolve.html)
-endif()
-
-if (BUILD_corbaidl2wrs)
- list(APPEND INSTALL_FILES ${CMAKE_BINARY_DIR}/doc/idl2wrs.html)
-endif()
-if (BUILD_xxx2deb)
- list(APPEND INSTALL_FILES
- ${CMAKE_BINARY_DIR}/doc/asn2deb.html
- ${CMAKE_BINARY_DIR}/doc/idl2deb.html
- )
-endif()
-
if(WIN32)
set(TEXTIFY_FILES COPYING NEWS README.windows)
set(TEXTIFY_MD_FILES README.md)
@@ -2006,7 +1972,6 @@ foreach(_install_file ${INSTALL_FILES})
"${_install_file_src}"
"${_output_file}"
DEPENDS
- docs
"${_install_file}"
)
list(APPEND copy_data_files_depends "${_output_file}")
@@ -2035,7 +2000,6 @@ if(LUA_FOUND AND ENABLE_LUA)
)
endforeach()
endif(LUA_FOUND AND ENABLE_LUA)
-# doc/*.html handled elsewhere.
# Glob patterns relative to the source directory that should be copied to
# ${DATAFILE_DIR} (including directory prefixes)