aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2023-01-13 18:02:34 -0800
committerGerald Combs <gerald@wireshark.org>2023-01-14 02:28:38 +0000
commitdd07fb5a15a3cae4f83d29418ef515bed40f658a (patch)
treeba9426cb9d7d271ef545f8ee31b1b0bfbb3d692a /CMakeLists.txt
parentad3205000b4bd1c2aefda9552e956d5e22d016e3 (diff)
CMake: Update a compiler version check
It looks like AppleClang 10 and 11 generate bogus missing braces warnings as well. The macOS Intel builder, which has AppleClang 11.0.0.11000033 installed, is failing with wireshark/epan/dissectors/packet-rtps.c:11403:63: error: suggest braces around initialization of subobject [-Werror,-Wmissing-braces] coherent_set_entity_info coherent_set_entity_info_object = {0}; ^ {}
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b4e2331c3..2d5cb7f85b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -695,7 +695,7 @@ else() # ! MSVC
#
if((CMAKE_C_COMPILER_ID STREQUAL "GNU" AND CMAKE_C_COMPILER_VERSION VERSION_LESS "5.1") OR
(CMAKE_C_COMPILER_ID STREQUAL "Clang" AND CMAKE_C_COMPILER_VERSION VERSION_LESS "6.0") OR
- (CMAKE_C_COMPILER_ID STREQUAL "AppleClang" AND CMAKE_C_COMPILER_VERSION VERSION_LESS "10.0"))
+ (CMAKE_C_COMPILER_ID STREQUAL "AppleClang" AND CMAKE_C_COMPILER_VERSION VERSION_LESS "12.0"))
if(NOT CMAKE_C_COMPILER_ID STREQUAL "GNU" OR CMAKE_C_COMPILER_VERSION VERSION_LESS "4.7")
list(APPEND WIRESHARK_C_ONLY_FLAGS -Wno-missing-field-initializers)
endif()