aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-11-11 18:09:22 +0000
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-11-12 17:33:13 +0000
commitca06d7e4fe59d997d0fa69eea5b025b48dcff6f8 (patch)
treec6d42cb772a5434c9344abc508b50b6e60419ff7 /CMakeLists.txt
parent76c4ca40592694d4ee72511934197a9b32f9c448 (diff)
Add an include sub-directory to the tree
Blind attempt to fix Debian package brokenness managing headers separately from install rules. Global public headers that don't fit any of the Wireshark libraries should be placed in include/. Eventually the C files in the root dir should be placed somewhere else as well (like src/) but this is not a priority. Fixes #17726.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e2147e5cb..d4a81f4368 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -393,6 +393,7 @@ endif()
include_directories(
${CMAKE_BINARY_DIR}
${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/include
)
if( DUMPCAP_INSTALL_OPTION STREQUAL "suid" )
@@ -3439,12 +3440,12 @@ set(SHARK_PUBLIC_HEADERS
cfile.h
cli_main.h
file.h
- ws_attributes.h
- ws_compiler_tests.h
- ws_diag_control.h
- ws_log_defs.h
- ws_symbol_export.h
- wireshark.h
+ include/ws_attributes.h
+ include/ws_compiler_tests.h
+ include/ws_diag_control.h
+ include/ws_log_defs.h
+ include/ws_symbol_export.h
+ include/wireshark.h
${CMAKE_BINARY_DIR}/ws_version.h
)