aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2022-01-12 12:00:42 -0800
committerA Wireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2022-01-13 09:11:24 +0000
commita6e24a623416ca08fc8c3bb339b4f275a6aa9c3d (patch)
tree12d4168d992879fda42e8b0992af02a691072ddd /CMakeLists.txt
parent5074b4d71791b6240829b53cf80c66c9f8ca7835 (diff)
macOS: Require Sparkle 1 for now.
The Sparkle project recently released Sparkle 2.0.0, which deprecates the version 1 API. Add version discovery to FindSparkle.cmake and require version 1 until we add support for the new API. Ping #17861.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b33d7ae79..9a04eb5b54 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1244,7 +1244,7 @@ if(BUILD_wireshark)
endif()
set(QT_FOUND ON)
if(APPLE)
- ws_find_package(Sparkle ENABLE_SPARKLE HAVE_SOFTWARE_UPDATE)
+ ws_find_package(Sparkle ENABLE_SPARKLE HAVE_SOFTWARE_UPDATE 1 EXACT)
endif()
if(Qt${qtver}Multimedia_FOUND)
set(QT_MULTIMEDIA_LIB 1)