aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2023-01-17 14:07:33 -0800
committerGerald Combs <gerald@wireshark.org>2023-01-18 20:37:08 +0000
commit5a9812ab6130c241ff304c2b76f0b57fb7cccde6 (patch)
tree2aa58a9de049361ad2d5954dd9bbb272bd011e14 /CMakeLists.txt
parenta5eb85a1d6d2667610d7e7c1833c6b03b1c0de8a (diff)
AppRun: Set various paths
Set our ld library path and our data, extcap, and plugin directories. Document WIRESHARK_EXTCAP_DIR and WIRESHARK_PLUGIN_DIR. Note that we might want to set our various directories relative to the program path.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 093c5c2106..3fd7bd639a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3654,6 +3654,7 @@ if(RPMBUILD_EXECUTABLE)
endif()
if(LINUXDEPLOY_EXECUTABLE AND _linuxdeploy_plugin_qt AND APPIMAGETOOL_EXECUTABLE)
+ configure_file(packaging/appimage/Wireshark-AppRun.in ${CMAKE_BINARY_DIR}/packaging/appimage/Wireshark-AppRun @ONLY)
# Require production builds (/usr + Release).
if (CMAKE_BUILD_TYPE STREQUAL "Release" AND CMAKE_INSTALL_PREFIX STREQUAL "/usr" )
add_custom_target(wireshark_appimage_prerequisites)
@@ -3688,7 +3689,7 @@ if(LINUXDEPLOY_EXECUTABLE AND _linuxdeploy_plugin_qt AND APPIMAGETOOL_EXECUTABLE
${_wireshark_appimage_exe_args}
--desktop-file=${_wireshark_ai_appdir}/usr/share/applications/org.wireshark.Wireshark.desktop
--icon-file=${CMAKE_SOURCE_DIR}/resources/icons/wsicon256.png
- --custom-apprun=${CMAKE_SOURCE_DIR}/packaging/appimage/Wireshark-AppRun
+ --custom-apprun=${CMAKE_BINARY_DIR}/packaging/appimage/Wireshark-AppRun
--plugin=qt
DEPENDS wireshark_appimage_appdir
)
@@ -4087,7 +4088,7 @@ if(SHELLCHECK_EXECUTABLE)
add_custom_command(TARGET shellcheck POST_BUILD
COMMAND shellcheck --external-sources
resources/stock_icons/svg-to-png.sh
- packaging/appimage/Wireshark-AppRun
+ packaging/appimage/Wireshark-AppRun.in
"packaging/macosx/ChmodBPF/root/Library/Application Support/Wireshark/ChmodBPF/ChmodBPF"
packaging/macosx/osx-app.sh.in
packaging/macosx/osx-dmg.sh.in