aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2022-07-05 17:44:54 -0500
committerGerald Combs <gerald@wireshark.org>2022-07-06 01:06:20 +0000
commit51cb2312088624c3b79e4e8fc82802d5a7f996ef (patch)
treeb5a598eec97dd5423995d2b824b10d00e33df835 /CMakeLists.txt
parentdd5e2f3b3f8a639d386c63d0dce62c823f46163d (diff)
CMake: Copy our DLLs to a DLL-specific directory.
Set our DLL build directory to the the target directory for wsutil.dll instead of DATAFILE_DIR.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cdb979e638..44ef04f582 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1992,7 +1992,7 @@ if(NOT WIN32)
endif()
if(USE_REPOSITORY)
- set(_dll_output_dir "${DATAFILE_DIR}")
+ set(_dll_output_dir "$<TARGET_FILE_DIR:wsutil>")
add_custom_target(copy_cli_dlls)
set_target_properties(copy_cli_dlls PROPERTIES FOLDER "Copy Tasks")
add_custom_command(TARGET copy_cli_dlls PRE_BUILD