aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2022-12-14 17:24:12 +0000
committerJoão Valverde <j@v6e.pt>2022-12-15 01:57:39 +0000
commit400235ad7edeca2a89cdfece18a83400eaa0df49 (patch)
tree567d39e46d62e3589687f30293d4a325108262e5 /CMakeLists.txt
parentf2caa6a0cc2fab5a242c09f8d50b9d901bfd253a (diff)
CMake: Re-enable -Wno-error=stringop-overflow=
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93d1f2546c..3364b79e72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -645,13 +645,16 @@ else() # ! MSVC
# a big nuisance because the warning is dormant and a low
# priority target for action. That is very disruptive
# with -Werror enabled (the default on the master branch).
+ #
# XXX Now that we have a CI job with Release build type (using
# -O3 optimization level) the dormancy issue should be ameliorated
# so comment out these exceptions to re-evaluate the impact.
- #
#-Wno-error=maybe-uninitialized
#-Wno-error=alloc-size-larger-than=
- #-Wno-error=stringop-overflow=
+ #
+ # XXX We still don't have a CI release build using Clang so keep
+ # Werror disabled with Wstringop-overflow for the reasons stated above.
+ -Wno-error=stringop-overflow=
#
# Updating external dependencies can introduce new deprecations.
# Also fixing new internal deprecations takes time.