aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <gharris@sonic.net>2021-02-15 14:31:14 -0800
committerGuy Harris <gharris@sonic.net>2021-02-15 14:31:14 -0800
commit2e9303b7b297402cf2725d5355c83adca56b60ba (patch)
tree95fe6b28c8ca76f9ef5e443b3ef15fb552854a55 /CMakeLists.txt
parent0ed0ab665f803aff8027790241cf8b3e6e586e66 (diff)
GitLab CI: use sed to strip out -W and -f options from output.
Filter out the -W and -f options from the output of "ninja rpm-package", to try to cut down the verbosity. Do that instead of passing --quiet to rpmbuild, so we get command progress messages, just without the extra junk.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt32
1 files changed, 0 insertions, 32 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 396a66fb4c..26ff0aa36d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3038,38 +3038,6 @@ if(RPMBUILD_EXECUTABLE)
if(CMAKE_VERBOSE_MAKEFILE)
list(APPEND _rpmbuild_with_args -v)
endif()
- #
- # This is ugly.
- #
- # At least some versions of rpmbuild define the cmake_build
- # macro to run "cmake --build" with the "--verbose" option,
- # with no obvious way to easily override that, so, if you
- # are doing a build with lots of source files, and with
- # lots of compiler options (for example, a log of -W flags),
- # you can get a lot of output from rpmbuild.
- #
- # Wireshark is a program with lots of source files and
- # lots of compiler options.
- #
- # GitLab's shared builders have a limit of 4MB on logs
- # from build jobs.
- #
- # Wireshark uses the shared builders, and can produce
- # more than 4MB with the Fedora RPM build; this causes
- # the builds to fail.
- #
- # Adding the -q flag to rpmbuild appears to squelch
- # most of the rpmbuild output. This is not ideal,
- # but it might at least let the builds succeed
- # without failing due to hitting the log file limit.
- #
- # We don't add -q by default; if the build has
- # the FORCE_CMAKE_NINJA_QUIET environment
- # variable set, it will add it.
- #
- if(DEFINED ENV{FORCE_CMAKE_NINJA_QUIET})
- list(APPEND _rpmbuild_with_args --quiet)
- endif()
if(CMAKE_GENERATOR STREQUAL "Ninja")
list(APPEND _rpmbuild_with_args --with ninja)
endif()