aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2022-06-02 15:07:09 -0700
committerGerald Combs <gerald@wireshark.org>2022-06-02 16:33:31 -0700
commit056fd8a1e3e67dc13835d8a79c8964bc65a23882 (patch)
treeef4613ed59b5d62fc6bdb7153af16fa0f61f3826 /CMakeLists.txt
parent709593ee91c87570964da82bb6b9c2de1043d32e (diff)
NSIS: Update some target and filenames.
Rename the following build targets, similar to the recent macOS target name changes: nsis_package_prep to wireshark_nsis_prep nsis_package to wireshark_nsis Rename some NSIS files to reflect that they're specific to Wireshark. Update the documentation and CI configurations.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d877ecbfe..0ddc11b964 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3131,8 +3131,8 @@ if (WIN32)
if(MAKENSIS_EXECUTABLE)
add_subdirectory( packaging/nsis EXCLUDE_FROM_ALL )
- ADD_NSIS_UNINSTALLER_TARGET()
- ADD_NSIS_PACKAGE_TARGET()
+ ADD_NSIS_UNINSTALLER_TARGETS()
+ ADD_NSIS_PACKAGE_TARGETS()
endif()
find_package( WiX )
@@ -3339,7 +3339,7 @@ if(ENABLE_APPLICATION_BUNDLE AND BUILD_wireshark)
ADD_CUSTOM_TARGET( wireshark_dmg
COMMAND bash -x ${CMAKE_BINARY_DIR}/packaging/macosx/osx-dmg.sh
- # Unlike nsis_package_prep + nsis_package, we can add a direct
+ # Unlike wireshark_nsis_prep + wireshark_nsis, we can add a direct
# dependency here.
DEPENDS wireshark_dmg_prep
# We create Wireshark.app in "run". Do our work there.
@@ -3393,7 +3393,7 @@ if(ENABLE_APPLICATION_BUNDLE AND BUILD_logwolf)
# ADD_CUSTOM_TARGET( logwolf_dmg
# COMMAND bash -x ${CMAKE_BINARY_DIR}/packaging/macosx/osx-dmg.sh
- # # Unlike nsis_package_prep + nsis_package, we can add a direct
+ # # Unlike wireshark_nsis_prep + wireshark_nsis, we can add a direct
# # dependency here.
# DEPENDS wireshark_dmg_prep
# # We create Wireshark.app in "run". Do our work there.