aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-28 09:07:12 +0100
committerJoão Valverde <j@v6e.pt>2016-03-29 14:05:48 +0000
commit26f3a9aa844924fe4a7d89982d3c4b0dce440a7c (patch)
tree0e10851b8aac1fabb9f1281103dba6838e37c626 /CMakeLists.txt
parentc436452769d7751d2afd347a4953b4628be17836 (diff)
Use "old-style" moc options to ensure backward compatibility for Qt tools
Change-Id: Ic96df4ba521e0fbaf4ac34f23e3a89304ed5de5c Reviewed-on: https://code.wireshark.org/review/14662 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5a12d998a..bfb33bd01d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -962,7 +962,8 @@ if (Qt5Widgets_FOUND)
# set(QT_WINEXTRAS_LIB 1) # Not needed?
endif()
if(NOT DEFINED MOC_OPTIONS)
- set(MOC_OPTIONS --no-notes)
+ # Squelch moc verbose "nothing to do" output
+ set(MOC_OPTIONS -nn)
endif()
# If Qt4: QT_LIBRARIES and QT_INCLUDES are not set above. They require extra magic
elseif(QT_FOUND)