aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-12-29 12:12:26 +0000
committerJörg Mayer <jmayer@loplof.de>2009-12-29 12:12:26 +0000
commit9a69a7934e3c7e404d09cb18ae1c8a14637d9b5d (patch)
treed6efe47a35ca8e4cf1be8ea0e61aae325dc29534 /CMakeLists.txt
parentd0cd08b6798bde869fcb435a4ad70267cfb048c0 (diff)
- Beginnings of cmake in docbook directory
- Add note about "make help" - Move beginnings of packaging into its own file: CPackConfig.txt svn path=/trunk/; revision=31379
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 4 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53b99e51a3..21eacc1250 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -274,6 +274,9 @@ endforeach()
find_package(YAPP)
+#packaging
+include(CPackConfig.txt)
+
if(HAVE_LIBPYTHON)
set(HAVE_PYTHON 1)
set(PYTHON_DIR "${CMAKE_INSTALL_PREFIX}/lib/wireshark/python/${CPACK_PACKAGE_VERSION}")
@@ -307,22 +310,6 @@ include(ConfigureChecks.cmake)
include(TestBigEndian)
test_big_endian(WORDS_BIGENDIAN)
-#packaging
-set(CPACK_PACKAGE_NAME wireshark)
-set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "capture packet")
-set(CPACK_PACKAGE_VENDOR "wireshark")
-set(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}/README")
-set(CPACK_RESOURCE_FILE_LICENSE "${CMAKE_CURRENT_SOURCE_DIR}/COPYING")
-set(CPACK_PACKAGE_VERSION_MAJOR "1")
-set(CPACK_PACKAGE_VERSION_MINOR "3")
-set(CPACK_PACKAGE_VERSION_PATCH "3")
-set(CPACK_PACKAGE_VERSION "${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}")
-
-set(CPACK_SOURCE_PACKAGE_FILE_NAME "${CPACK_PACKAGE_NAME}-${CPACK_PACKAGE_VERSION}")
-set(CPACK_PACKAGE_INSTALL_DIRECTORY "/usr")
-set(CPACK_GENERATOR "TGZ")
-set(CPACK_SOURCE_GENERATOR "TGZ")
-
set(DATAFILE_DIR "${CMAKE_INSTALL_PREFIX}/share/${CPACK_PACKAGE_NAME}")
if(ENABLE_PLUGINS)
@@ -368,8 +355,7 @@ add_subdirectory( wiretap )
add_subdirectory( wsutil )
if(ENABLE_GUIDES)
-# todo
-# add_subdirectory( docbook )
+ add_subdirectory( docbook )
endif()
#Platform specific