aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2010-02-25 12:30:44 +0000
committerJörg Mayer <jmayer@loplof.de>2010-02-25 12:30:44 +0000
commit914983a0dce85c43d8bd8e7c396d3a9c1d44ff63 (patch)
tree4f012ed120f8cd9530dcc035be8ee6552f952997 /CMakeLists.txt
parent480582e8e91c409ec8a729ff6c79a2814c50273d (diff)
Almost working out-of-tree builds for the documentation,
with a few hacks right now: - The tip.png, warning.png and note.png images are missing from the pdfs and I have no idea how to tell fop how to find them. - Disabling/enabling building the guides via option currently doesn't work (probably too many macros :-), so comment out the subdir instead. - Right now, in order to build the devleopers guide we need to do the following in the source docbook directory: touch wsdg_graphics/toolbar/dummy.dummy Apart from these: The build works with a pristine docbook dir (svn status --no-ignore). svn path=/trunk/; revision=32004
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f59791808..ff34f23a9b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,7 @@
project(Wireshark C)
cmake_minimum_required(VERSION 2.6)
+set(CMAKE_BACKWARDS_COMPATIBILITY 2.6)
#Where to find local cmake scripts
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
@@ -69,10 +70,11 @@ option(AUTOGEN_pidl "Autogenerate pidl dissectors" OFF)
option(DISABLE_WERROR "Do not treat Warnings as errors" OFF)
option(ENABLE_EXTRA_GCC_CHECKS "Do additional -W checks in GCC (disables -Werror)" OFF)
option(ENABLE_AIRPCAP "Enable Airpcap support" ON)
+# todo
option(ENABLE_STATIC "Build a static version of Wireshark (not yet working)" OFF)
option(ENABLE_PLUGINS "Build with plugins" ON)
# todo
-option(ENABLE_GUIDES "Build Guides (not yet implemented)" OFF)
+option(ENABLE_GUIDES "Build Guides" ON)
option(ENABLE_ADNS "Build with adns support" ON)
option(ENABLE_PCRE "Build with pcre support" ON)
@@ -355,9 +357,12 @@ add_subdirectory( wiretap )
add_subdirectory( wsutil )
if(ENABLE_GUIDES)
- add_subdirectory( docbook )
+# FIXME: Disabling the build via option currently doesn't work
+# add_subdirectory( docbook )
endif()
+find_package(POD)
+
#Platform specific
if(UNIX)
set(WS_VAR_IMPORT "extern")
@@ -805,8 +810,6 @@ ADD_CUSTOM_COMMAND(
tshark
)
-find_package(POD)
-
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/capinfos 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/dumpcap 1 )
pod2manhtml( ${CMAKE_SOURCE_DIR}/doc/editcap 1 )