aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-08-02 07:20:43 +0000
committerJörg Mayer <jmayer@loplof.de>2013-08-02 07:20:43 +0000
commit87ca12fcb76c7f684b6d6df42d460fe1f087fa84 (patch)
tree5e068fc73acaacc7603b36c4fdfebbef71f6617d /CMakeLists.txt
parentd01744397910ec664363725c0e8e7af9746a1682 (diff)
Print the flag we are testing
svn path=/trunk/; revision=51116
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6521cbe9aa..b35afff8f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,6 +215,7 @@ foreach(THIS_FLAG ${WIRESHARK_C_FLAGS})
set(F WS_C_FLAG_${C})
set(${F} ${THIS_FLAG})
set(V WS_C_FLAG_VALID${C})
+ message(STATUS "Checking for flag: ${${F}}")
check_c_compiler_flag(${${F}} ${V})
if (${${V}})
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${${F}}")
@@ -227,6 +228,7 @@ foreach(THIS_FLAG ${WIRESHARK_C_ONLY_FLAGS})
set(F WS_C_FLAG_${C})
set(${F} ${THIS_FLAG})
set(V WS_C_FLAG_VALID${C})
+ message(STATUS "Checking for flag: ${${F}}")
check_c_compiler_flag(${${F}} ${V})
if (${${V}})
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${${F}}")