aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-06-01 00:13:25 +0000
committerJörg Mayer <jmayer@loplof.de>2013-06-01 00:13:25 +0000
commit7ad85db8e166f5bb3726f1701dfdc065655405fb (patch)
treea81fedda2df7f76ac0c158fe2a318427b206e312 /CMakeLists.txt
parentbbdb29725a0a408433c88f402aff212e8048ce75 (diff)
Move -Wlogical-op to list of standard compiler flags for c-only.
svn path=/trunk/; revision=49668
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b87fccf358..70a4cf3191 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -135,6 +135,7 @@ set(WIRESHARK_C_ONLY_FLAGS
# The following are C only, not C++
-Wc++-compat
-Wdeclaration-after-statement
+ -Wlogical-op
-Wno-pointer-sign
-Wold-style-definition
-Wshadow
@@ -143,7 +144,6 @@ set(WIRESHARK_C_ONLY_FLAGS
set(WIRESHARK_EXTRA_C_FLAGS
-pedantic
-Woverflow
- -Wlogical-op
-Wno-overlength-strings
-fstrict-overflow -Wstrict-overflow=4
-Wunreachable-code