aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2010-07-17 14:07:13 +0000
committerJörg Mayer <jmayer@loplof.de>2010-07-17 14:07:13 +0000
commit7807a0d84656de3c59f7ddf9fce7b228a12981af (patch)
treeb9a06fcfce11433e261a77f05306c9062fa3638f /CMakeLists.txt
parenteabe057c1ac5ee940d3a0acbbc2c0f5df5c366e1 (diff)
- Copy over from Makefile.am: dumpcap doesn't need to link
in libgcrypt and gnutls. - capinfos has a dependency on svnversion.h svn path=/trunk/; revision=33559
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd949da4f0..98c0bdae66 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -758,6 +758,7 @@ if(BUILD_capinfos)
${WTAP_PLUGIN_SOURCES}
)
add_executable(capinfos ${capinfos_FILES})
+ add_dependencies(capinfos svnversion)
set_target_properties(capinfos PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(capinfos ${capinfos_LIBS})
install(TARGETS capinfos RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
@@ -789,8 +790,6 @@ if(BUILD_dumpcap)
${CAP_LIBRARIES}
# @SOCKET_LIBS@
# @NSL_LIBS@
- ${GCRYPT_LIBRARIES}
- ${GNUTLS_LIBRARIES}
${ZLIB_LIBRARIES}
${APPLE_COCOA_LIBRARY}
)