aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2011-08-29 19:18:28 +0000
committerJörg Mayer <jmayer@loplof.de>2011-08-29 19:18:28 +0000
commit6c3a7ca052bbc1d2248ab98d2e261ad20ff9b4b9 (patch)
tree391b6a8af3e27ee688ee8258adfab92fb56e72e1 /CMakeLists.txt
parent5486a8814504eae58ff4215742047e18cf3f3ca9 (diff)
Only build rawshark and dumpcap if we have libpcap
svn path=/trunk/; revision=38780
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10719b083a..09100d7fd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -720,7 +720,7 @@ if(BUILD_tshark)
install(TARGETS tshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
-if(BUILD_rawshark)
+if(BUILD_rawshark AND PCAP_FOUND)
set(rawshark_LIBS
${LIBEPAN_LIBS}
${APPLE_COCOA_LIBRARY}
@@ -845,7 +845,7 @@ if(BUILD_editcap)
install(TARGETS editcap RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
-if(BUILD_dumpcap)
+if(BUILD_dumpcap AND PCAP_FOUND)
set(dumpcap_LIBS
# @INET_NTOP_LO@
wsutil