aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Maynard <Christopher.Maynard@GTECH.COM>2011-04-05 20:21:59 +0000
committerChris Maynard <Christopher.Maynard@GTECH.COM>2011-04-05 20:21:59 +0000
commit595e5e1c1d150812de9cc0d1549acd0ed5d8770d (patch)
treec0101435e5778ab84ef23a5809fa0332e5430fbf /CMakeLists.txt
parent4f462b3d09e661d64714187636ddb851457c1c39 (diff)
Add ICMP tap support, and add a tshark tap to measure such things as:
* Number of ICMP echo requests, replies, lost replies and percent loss. * Min, Max, Average SRT (Service Response Time), and standard deviation. (This is my first tap, so hopefully I didn't miss something, but we'll see ...) TODO: Add a Wireshark tap. svn path=/trunk/; revision=36480
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6cbc2a9c4d..097dac5fc9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -548,6 +548,7 @@ set(TSHARK_TAP_SRC
tap-h225counter.c
tap-h225rassrt.c
tap-httpstat.c
+ tap-icmpstat.c
tap-iostat.c
tap-iousers.c
tap-mgcpstat.c