aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2011-08-07 18:35:36 +0000
committerJörg Mayer <jmayer@loplof.de>2011-08-07 18:35:36 +0000
commit553c56569950e68fa9f2ca620325e1921814dfdc (patch)
treee4b56960256588b3dcbdbbc4e32751210b3a09bc /CMakeLists.txt
parentc15ff441c66bf3592c03936d8a08a69ac8402377 (diff)
mate_grammar.lemon:
- Fix a bug my previous patch introduced. mate/: - Unset G_DISABLE_DEPRECATED for the mate files. CMakeLists.txt configure.in: - Build with -DG_DISABLE_DEPRECATED so further usage of deprecated glib functions will be detected. svn path=/trunk/; revision=38393
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e8329825c..32051badfd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,9 +27,11 @@ cmake_minimum_required(VERSION 2.6)
set(CMAKE_BACKWARDS_COMPATIBILITY 2.6)
# Needs to be set after cmake_minimum_required or cmake_policy(VERSION)
-#if(COMMAND cmake_policy)
+if(COMMAND cmake_policy)
+ # Backward compatibility for versions < 2.6.3
+ cmake_policy(SET CMP0011 OLD)
# cmake_policy(SET CMP0015 NEW)
-#endif(COMMAND cmake_policy)
+endif(COMMAND cmake_policy)
# set(PROJECT_VERSION "1.3.4-rc5")
# set(PROJECT_VERSION "1.3.4rc5")
@@ -158,6 +160,7 @@ endif()
add_definitions(
-DHAVE_CONFIG_H
+ -DG_DISABLE_DEPRECATED
)
# Counterhack to work around some cache magic in CHECK_C_SOURCE_COMPILES