aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaap Keuter <jaap.keuter@xs4all.nl>2011-02-21 21:33:54 +0000
committerJaap Keuter <jaap.keuter@xs4all.nl>2011-02-21 21:33:54 +0000
commit4dd920a9aa5a46e6bb69d467c8afa39687621ed9 (patch)
treef9d7e19185d4dce2a076fcb42ceeb31b7a575877 /CMakeLists.txt
parentaf7e7f1004436bf2193eee5a071d26662be7861c (diff)
From Roland Knall:
WS_MSVC_NORETURN is undeclared under a non-Windows operating system, which breaks compilation in the files epan/except.c and dumpcap.c as well as any file including epan/except.h svn path=/trunk/; revision=36023
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 902c13a016..6cbc2a9c4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -434,11 +434,14 @@ endif()
if(WIN32)
add_definitions(-D_NEED_VAR_IMPORT_)
set(WS_VAR_IMPORT "__declspec(dllimport) extern")
+ set(WS_MSVC_NORETURN "__declspec(noreturn)")
# Disable deprecation
if(MSVC80 OR MSVC90)
add_definitions(-D_CRT_SECURE_NO_DEPRECATE -D_CRT_NONSTDC_NO_DEPRECATE)
endif()
+else()
+ set(WS_MSVC_NORETURN " ")
endif()
configure_file(${CMAKE_SOURCE_DIR}/cmakeconfig.h.in ${CMAKE_BINARY_DIR}/config.h)