aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2010-05-24 21:59:29 +0000
committerJörg Mayer <jmayer@loplof.de>2010-05-24 21:59:29 +0000
commit47e4c55698f2c7eb40f1f0eca1b65389f0ae97bd (patch)
tree01e57ee79c45ca24f079e895394bff26da5f4b1b /CMakeLists.txt
parentb8812638dcc2334bbd1524c950044785b664e56e (diff)
- Add a comment about the magic in the FindXXX.cmake filenames.
- Fix for https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4786 Define HAVE_PCAP_VERSION if HAVE_PCAP_LIB_VERSION is set. svn path=/trunk/; revision=32936
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ceb0e49cf5..46e438ca13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -209,6 +209,13 @@ else()
set(LINK_MODE_MODULE MODULE)
endif()
+# The packagelist is doing some magic: If we add XXX to the packagelist, we
+# - may optionally set XXX_OPTIONS to pass to the find_package command
+# - will call FindXXX.cmake
+# - return found libraries in XXX_LIBRARIES
+# - return found include in XXX_INCLUDE_DIRS
+# - set HAVE_XXX
+
#The minimum package list
set(PACKAGELIST GLIB2 PCAP M LEX YACC Perl SH PythonInterp HtmlViewer ${PACKAGELIST})
@@ -330,6 +337,10 @@ endif()
if(ENABLE_AIRPCAP)
set(HAVE_AIRPCAP 1)
endif()
+# Assume that if HAVE_PCAP_LIB_VERSION exists, then HAVE_PCAP_VERSION exists as well
+if(HAVE_PCAP_LIB_VERSION)
+ set(HAVE_PCAP_VERSION 1)
+endif()
# That's the name autofoo uses
if(HAVE_LIBZLIB)
set(HAVE_LIBZ 1)