aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2012-08-19 00:14:14 +0000
committerJörg Mayer <jmayer@loplof.de>2012-08-19 00:14:14 +0000
commit4546cfeab5ee8470aef21b2f47db92d62cc3b9cb (patch)
tree8ea79cc0fda7186d33e326361969279a5c37e178 /CMakeLists.txt
parent5e17f4606f98426964d0d39873f25646cf321523 (diff)
Commit 44474 added some arguments to the ac_init macro that broke
extraction of the wireshark version for cmake. Now the version part is either terminated by ")" (old) or "," (added). It looks like .*? does not exist for non-greedy matches in cmake regex. svn path=/trunk/; revision=44570
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db0ab5296d..c650a64fe0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,7 +43,7 @@ if(NOT PROJECT_VERSION)
VERSIONLINE
REGEX "\\(wireshark, .*\\)"
)
- string(REGEX REPLACE ".*\\(wireshark, (.*)\\).*"
+ string(REGEX REPLACE ".*\\(wireshark, ([^,)]*).*"
"\\1"
PROJECT_VERSION
${VERSIONLINE}