aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-09-10 21:24:52 +0000
committerGerald Combs <gerald@wireshark.org>2013-09-10 21:24:52 +0000
commit17678f9b5d48f8f09695877d03d09f1f86b7e943 (patch)
treecc8b9307182fcf72e1d64002c639735e2b9e6bd1 /CMakeLists.txt
parent84069ac0eb693a55a09da22baf80f58075d8a419 (diff)
Homebrew installs gettext (including libintl, which GLib requires) in
/usr/local/opt/gettext. Tell CMake to update our include and library paths accordingly. svn path=/trunk/; revision=51943
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2991099b1f..9a1020340a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,6 +280,13 @@ else()
set(LINK_MODE_MODULE MODULE)
endif()
+if(APPLE AND EXISTS /usr/local/opt/gettext)
+ # GLib on OS X requires libintl. Homebrew installs gettext (and
+ # libintl) in /usr/local/opt/gettext
+ include_directories(/usr/local/opt/gettext/include)
+ link_directories(/usr/local/opt/gettext/lib)
+endif()
+
# The packagelist is doing some magic: If we add XXX to the packagelist, we
# - may optionally set XXX_OPTIONS to pass to the find_package command
# - will call FindXXX.cmake